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1. Introduction 

1.1 System summary 
The Firefly optical motion capture system is designed to track the motion of any object (a 
human body, vehicles, models, etc…).  It is ideally suited for the development of 
computer games, the production of computer animation, as a input device for virtual 
reality applications, and in providing data for human biomechanic or ergonomic studies.  
The most common systems used today utilize either magnetic field or optical tracking 
techniques to capture human motions.  In comparison with the Firefly, the magnetic 
systems are costly, not as accurate and suffer from inherent limitations when used near 
metal objects and structures.  The optical systems most commonly used today are 
accurate, very expensive, and require extensive calibration before the motion capture 
sessions, and off-line processing after the sessions. 
 

 
 
The basic Firefly motion capture system consists of one camera array, one tag controller, 
32 tags, and accompanying cables.  The Firefly measurement system consists of  three 
charge-coupled device (CCD) cameras mounted on a 1 meter rigid bar.  By imaging 
infrared light emitting diode (IR LED) tags, this camera array can accurately determine 
their 3D position in real time.  Since the camera array is precalibrated, there is no 
calibration required which means that you can immediately begin using the system to 
accurately track tags. 
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The tag controller is a small, battery operated waist mounted unit that is used to strobe the 
active tags.  The tag controller does not need to be tethered to the array, since the system 
is auto synchronizing when the tags are in view of the array.  Should the tags be not in 
near continuous view of the array, then a synchronizing cable is recommended (included.)  
The system can be configured to track up to 256 tags with multiple slaved tag controllers. 
 
The tags are small, wide angle emission IR LEDs that are virtually massless.  They are 
designed to be attached by adhesives to a persons skin, or can be attached via thread to 
gloves, elastic bands, special garments, etc.  To be tracked they must be in the 
simultaneous field of view of all three cameras in the camera array.  When not in view, 
the data can be filtered to produce continuous uninterrupted data at a greater latency.  
Alternately, multiple camera arrays can be slaved together to eliminate virtually all line of 
sight problems. 
 
The Firefly system maintains the accuracy of the optical systems while providing motion 
data real-time at a reasonable cost.  This makes the Firefly motion capture system ideal 
for an in-house motion capture capability for any game developer, animator, virtual 
reality environment creator, or researcher. 

1.2 Purpose of this manual 
In this manual you will find out exactly what the Firefly is capable of, as well as how to 
perform a collection of data, and how to view and analyze the data through a bodytracker 
specific program, or through the Data Collection Broker (DCB). 

1.3 System requirements 
The bodytracker requires a serial port to plug into the computer on which the controlling 
software will reside.  Firefly Control software requires a Pentium 166, with 5 megabytes 
of free space, and a memory requirement of 64 MB RAM.  The minimum DCAE 
software requirements are:  a Pentium 233, with 20 MB of free space, and 64 MB of 
RAM. 
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2. Installation Instructions 

2.1 System Components 
The basic Firefly Tracking System consists of the following parts: 
 
Firefly tracker 

 
 
Tag Controller      32 Tags (2 shown) 

  
 
Not Shown: 
• Power Cord 
• Serial Connection Cable 
• Tag Controller Cables 
• System Software 
 
Some systems will have either a wired or wireless Tag Controller.  Both Tag Controllers 
function in the same manner.  More than 32 tags are available.  Contact Cybernet Systems 
Corporation for purchasing information. 

2.2 Selecting a location for the tracker 
The tracker has an effective range of (roughly) 8 meters long, with a field of view of 
40x40 degrees.  You will want to position the camera array so that there very little or 
nothing but open space in the sensing area.  For your own tracking purposes, you may 
want walls within your tracking area, as a frame of reference (by placing tags on the 
walls). 
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Suggested configurations: 
• Table mount - attach the camera array to a table.  Benefits are mobility (if the 

table has wheels). 
• Wall mount - provides greater sensing area 
• Ceiling mount - provides the greatest area.  By mounting the array at the 

corner of the ceiling and the wall, and angling the array down, you can get a 
good sensing area. 

• Tripod mount - mobile, and height adjustable.  This is the most versatile of the 
mounting options, and is highly suggested. 

2.3 Plugging In  
All connections to the camera array are made along the back side of the array. 
 
1. Plug the camera array into the serial connector on your computer. 
2. Plug the tag controller to the array (if you have a wireless system, do nothing). 
3. Plug the array into the power cube, and then into a wall socket. 

2.4 Installing the software  
If you purchased the Firefly alone: 
Insert the disk marked Firefly Install into your computer.  Copy the files there onto your 
hard drive, or double-click the install icon, and follow the on-screen instructions. 
 
If you purchased Firefly as a part of the Human Performance Measurement System, or 
have a copy of the DCAE, you will need to run the install program as outlined in the Data 
Collection and Analysis Environment (DCAE) System Overview document.  Choose the 
Custom Install option, and select the Firefly.exe section to install. 

2.5 Activating the System 
Once plugged in to an active power source, the camera array is active.  The tag controller 
needs to be connected to the array (unless you have a wireless system) and turned on via 
the tag controller’s power switch.  When the tag controller is operating, the yellow LED 
on the controller should be slowly flashing. 
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3. The Tag Controller 

3.1 Tag Controller basics 
The Tag Controller is the device that controls the flashing of the IR LED tags that the 
cameras track.  Each controller can accommodate up to 32 tags, and connect to another 
controller.  When tracking human motion, this device is most often worn on a belt, or 
attached in some way to the device being tracked (but this is not necessary), and is only 
slightly larger than pictured here, and is very light weight. 
 

 
 
Tag number is important, as when you look at the collected data later, you’ll want to 
know which tag was placed where on a person or object. 

3.2 Applying the Tags 
Tag Anatomy  
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Each tag has an IR LED (the tag part), a black tag holder, a wire of a certain length, and a 
connector socket for connection to the controller (not shown above). 
 
The basic Firefly package comes with 32 tags of varying lengths.  Contact Cybernet 
Systems Corporation if you need tags of a specific length, or more than 32 tags. 
 
When attaching the tags to an object, the black tag holder is always the point of contact.  
The holder has 4 holes in it for sewing the tag onto a cloth surface, like a jumpsuit or 
velcro band.  
 
The black holder is also an ideal surface for hot-glue, when the tag needs to be attached to 
a hard surface. 
 
When sewing tags into a jumpsuit, brace, or attaching tags to any hard surface, it is 
suggested that you have an idea of how the tags might become occluded during the course 
of recording data from the moving object.  By giving a little thought into the placement of 
tags, and by placing secondary tags in certain high-occlusion-risk locations, you will 
improve your chances of not missing any important data. 
 
If you are uncertain about hardmounting your tags to certain locations, we suggest that 
you hot-glue the tags each to their own ‘tie-tack’ or safety pin.  This way, the tag can be 
attached to clothing at any location, and moved around as situations require. 
 
It is important to note, though, that errors in tracking may occur if the tags are attached 
this way.  Tags may move, clothes may fold, and tags can become occluded. 

3.3 Connecting 2 tag controllers to a single tracker 
Multiple tag controllers can be linked together via a small cable connection in order to 
allow the use of more than 32 tags.  The Firefly software can support up to 256 tags.  The 
maximum number of tags would require 8 tag controllers.  A primary tag controller is 
linked to the Firefly (either via a wired or wireless link), and all other tag controllers are 
then connected to that primary controller.  This allows all the tag controllers to be 
synchronized. 
 
If needed, custom tag controllers can be constructed  by Cybernet Systems Corporation 
where the number of tags to be controlled or the physical packaging is specified. 
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4. FireFly Control Software 

4.1 Quick Start Instructions 
1. Open the Firefly.exe program by double-clicking the icon. 
2. Selecting Your Data - The Firefly can display data real time, or from a previously 

recorded file.  To select the mode, from the File menu, select “Set Mode.”  At this 
point you will be presented with a dialog box containing two choices.  “Real Time” 
and “Replay.”  Select the appropriate one, and click “OK.”  If you are viewing old 
data from a file, you will need to then go to the File Menu, and select ‘Open Data 
File’.  You will then be prompted to find the file you want through a standard file 
selection dialog. 

3. Create and/or Apply a Configuration file - From the File Menu, select the ‘Open 
Config’ option.  This will call up a standard open file dialog.  A configuration file will 
connect the points displayed in a specific pattern.  For more information on creating 
configuration files, see section 4.3. 

4. The real time data or the file can then be displayed by either clicking the Play arrow 
on the toolbar, or by selecting Start from the File menu. 

5. Save Data - (only necessary for real-time data)  From the File Menu, select the ‘Save 
As…’ option.  Data will be saved starting after you have selected a file name to save 
as.  You can close a save file (stop saving) by selecting ‘Start’ from the File Menu, 
pressing the Play button on the toolbar, or selecting ‘Save As…’ again. 

6. To stop real-time data collection or a file playback, click the Play button on the 
toolbar or select ‘Start’ from the file menu. 

7. Exit the program using the X box in the upper right corner, or the ‘Exit’ option from 
the File Menu. 
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4.2 Image Manipulation 

 
 
The image can be rotated about its origin.  The S and X keys rotate the image about its X 
axis, the D and C keys rotate it about its Z axis, and the F and V keys rotate it about its Y 
axis.  The image can also be moved linearly with the number pad.  Numbers 4 and 6 slide 
the image left and right.  8 and 2 slide the image up and down.  9 and 3 move the image 
forward and back.  The 5 on the number pad resets the image orientation and position.  
 
The About dialog box (accessible from the Help menu and pictured above) has a 
summary of these keys. 

4.3 File Menu 
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Set Mode 

 
 
This dialog selects the method by which the Firefly software will receive data.  The 
options are Real-Time (directly from an actively collecting motion tracker), or Replay 
(replaying previously collected and saved data from a file). 
 
Start 
Selecting this option will either begin the displaying of real-time data or begin to play a 
selected data file. 
 
Open Data File 
This command will call up a standard ‘Open File Dialog’ to allow you to select a data file 
containing Firefly data. 
 
Open Config 
Configuration files are text files.  The first line determines the number of points to be 
tracked.  The following lines determine which points are to be connected by lines.  Note 
the example configuration file below: 
 

 
 
This configuration file sets the program to track the first 32 points.  (Tags 0 through 31.)  
It also establishes lines between points 0 and 16, 1 and 3, 2 and 3, 3 and 19, and between 
points 4 and 20.  There is no restriction on the length (in terms of lines) of this file, but 
the first line must agree with the tag controller configuration (default is to track 32 
points). 
 
Save As 
To save data to the hard drive, set the display mode to Real Time, and start displaying the 
data.  Once you are satisfied with the data reception, go to the File menu and select Save 
As.  This will bring up a file dialog box and allow you to choose or name the data file to 
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write to.  If an existing data file is chosen, its contents will be destroyed and overwritten.  
If a data file is being recorded when the Save As command is issued, it will be closed 
before the new file starts recording.  The data file will also be closed when the collection 
is stopped.  (By selecting Start from the File menu again, or clicking on the Play icon on 
the tool bar again.) 
 
Exit 
This command will exit the Firefly software. 

4.4 Options Menu 

 
 
Point Quality 
Each point has a quality associated with it at each frame.  This is a number from 0 to 15 
that represents the reliability and accuracy of the data at that point and at that time.  A 
point with a low quality would be unreliable data.  In such a case, the tag may be 
obscured by an object or by lose clothing.  A point with a high quality would be more 
reliable data.  The viewer can be set to omit points of less than a certain quality value.  To 
do this, select the Change Quality option from the Options Menu.  In the resulting dialog 
box, you may enter a number between 0 and 15 as the new minimum quality to display. 
 

 
 
Setting zero as the minimum quality will display all the points regardless of data quality.  
This is the default. 
 
Low Gain 
Sets the Firefly cameras to a low level of gain.  This is the default setting. 
 
Medium Gain 
Sets the Firefly cameras to a medium level of gain for potentially better tag detection. 
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High Gain 
Sets the Firefly cameras to a high level of gain for potentially better tag detection. 
 
Increase Gain 
Increments the gain on the Firefly cameras in units of 1. 
 
Decrease Gain 
Decrements the gain on the Firefly cameras in units of 1. 
 
Reset Timer 
Resets the internal Firefly collection timer to 0 seconds. 
 
Send Command 

 
 
This option brings up a window where you can type commands which are sent directly to 
the Firefly.  A partial list of commands can be found in the final appendix.  Note that this 
feature is for advanced users only.  The majority of these commands can be performed 
through the graphical menu system. 

4.5 View Menu 

 
 
Toolbar 
This is a toggle for displaying or hiding the tool bar which contains the Play and Help 
buttons. 
 
Status 
This feature is a toggle for displaying or hiding the Status Bar.  The Status Bar is not 
currently and operational feature of the Firefly software, and thus this toggle does 
nothing.  Future releases of this software will include this added feature. 
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4.6 Help Menu 

 
 
This menu will display the About dialog box which contains a summary of the image 
movement keys.  See section 4.2 for more details. 

4.7 Tool Bar Operations 

 
 
Presently, there are only two Tool Bar options.  The Play button causes the viewer to 
begin either displaying information from the Firefly, or replaying data from a file 
(depending on the mode.)  The Help button (question mark) displays the About dialog 
box which contains a summary of the image movement keys.  See section 4.2 for more 
details. 
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5. Controlling Fire Fly through the DCAE 
For more in-depth information on any of the parts of the DCAE described here, please 
consult the appropriate documentation. 

5.1 DCAE Firefly Quickstart Instructions 
1. Start the DCB GUI.  It can either be reached from it’s icon in the DCAE folder, or 

from the Start Menu, Programs, Dcae, DCB GUI. 
2. Load the Bodytracker driver.  Under the Drivers option from the main GUI window, 

select the ‘Load’ button.  From the Node pull-down menu, select the machine that the 
Firefly is connected to.  From the Driver pull-down menu, select Body Tracker.  You 
may give the driver an alias.  If a configuration file exists for the Body Tracker, it can 
be edited by clicking change at this point.  If a configuration file does not yet exist, 
the driver must be loaded with the default settings.  Add the driver by clicking Add, 
then click Done.  The driver is now loaded. 

3. Start a collection.  The Firefly must be turned on, connected to the computer running 
the DCB GUI, and the Tag Controller must be turned on. 

4. Open the APS (if necessary).  If the APS is already open, refresh the stream view so 
that the new data being collected will be available to view. 

5. Select all of the necessary data. 
6. Open the Bodytracker Viewer. 
7. If you are viewing data in real-time, from the Viewer Menu, select the ‘Real-Time’ 

option.  If you are playing back previously recorded data, open the Playback Controls 
from the Playback Menu.  Note that the Bodytracker Viewer works best when 
displaying data by Frame #.  This setting can be changed through the Playback 
controls. 

8. Create and/or Select a configuration file.  A configuration file will draw lines to 
connect the points of data being displayed to better represent the object being tracked.  
For more detailed information on how to create a configuration file, see below.  From 
the Viewer Menu, select ‘Properties’, then the ‘Configure’ option.  Select the 
appropriate configuration file, and it will automatically be applied to the data being 
displayed. 

9. Exit the viewer when finished. 

5.2 Driver Configuration 
Note:  This section contains information on how to configure the driver which translates 
information from the Firefly for use by the APS.  It does not contain information on how 
to make a configuration file for the purpose of drawing lines to connect data points. 
 
You will need to load the Bodytracker driver before you can modify any of the 
parameters.  You can opt to modify the driver (or create a new driver) from the 
‘Configuration File - Change’ button in the ‘Load Drivers Dialog’, or from the 
‘Reconfig.’ Button in the Driver Information section of the DCB GUI main screen (the 
Bodytracker driver needs to be highlighted in the graphical node view).   
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The BodyTracker driver consists of  5 parameters: 
• TagsToTrack - this number indicates to the DCB the number of tags (starting 

with tag 0) that the driver needs to collect data on and send to the APS.  In the 
below example, only tags 0-5 will be saved and displayed as available streams 
in the APS. 

• NumTags - this is the total number of tags that the FireFly is currently 
collecting data for.  Unless you have configured the Firefly Tag controller to 
something specific, this number should not be changed. 

• Driver - this is simply an indication of the type of driver file that this file is, 
and should not be changed or you will lose the file. 

• Demo - this parameter can be either ‘true’ or ‘false’.  Demo mode will inform 
the Firefly to produce a circular set of points as a demonstration.  Demo mode 
is generally only used for testing, and should remain as ‘false’. 

• CommPort - this variable sets tells the driver which serial port you have 
connected the Firefly into on your computer. 

 

 

5.3 The Analysis and Playback System Bodytracker Viewer 

5.3.1 Body Tracker Viewer Overview 
The Body Tracker Viewer requires a very specific set of data that is output by Cybernet’s 
Firefly Body Tracking system.   
 
Please note that there are 4 data fields for each tag, and all 4 data fields must be selected.  
These fields are:   
 

• QualityNumberA 
• X_PositionA 
• Y_PositionA 
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• Z_PositionA 
‘A’ refers to the number of the tag. 
 

 
 

Once you have selected the Body Tracker Viewer for a data stream you will see the Body 
Tracker viewer window containing the data points you just selected starting with Frame 
#0. 
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5.3.2 Viewer Menu  

 
 

1.  Synchronize - Allows playback and synchronization of this viewer with other 
viewers in the APS system through the playback controls. The default is off. 

2.  Real Time - Sets the viewer for real time viewing, where the current data is 
displayed as it is collected.  The default setting is on. 

3.  Time/Frame Format - Allows you to change the display units to either Frame # 
(the default), Real Time, or Test Time.  The Body Tracker Viewer works best 
in Frame Number mode. 

4.  Properties - Brings up dialog box for setting viewer parameters. Definition of 
alarm states, selection of display symbols/graphics, and setting of other 
features is performed. 

5.  Close - This closes the viewer. 
 
Properties 
The configure option, under the Properties selection, allows the user to select a 
configuration file that defines points to be connected by lines.  The configuration file is 
simply a text file that consists of a sets of points.  For example: 
 

 
 
This configuration file would connect points zero and three with a line.  It would also 
connect points one and three, and so on.  If the configuration specifies a point that is not 
being displayed, that connection is ignored.  The double slashes ‘//’ indicate a comment, 
and everything after the ‘//’ is ignored. 
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Below is an example of a collection of points with a configuration file arranged so that 
the points appear in the form of a stick-figure human: 
 

 

5.3.3 Quality 
In the Body Tracker, each point is assigned a “Quality” value which describes how 
reliable the data is.  A lower number means a higher probability that the point has an 
inaccurate location.  By using the Quality+ and Quality- menu options, the user can 
define the minimum quality a point needs to have to be displayed.  Any point with a 
lower quality will simply not be shown.  At a minimum quality of zero, all points are 
displayed, whether there is legitimate data for a given point or not.  The maximum quality 
is 15. 

5.4 Using the Text Viewer 
The raw data can be viewed in numeric form using the Text Viewer.  Simply select the 
data fields to be viewed, and click on the Text Viewer button.  The Text Viewer can then 
be synchronized with the Body Tracker Viewer via the Playback Control.   
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6. Appendix A - Technical Information 
Camera Array Dimensions: 4 inches (H) x 6 inches (D) x 50 inches (L) 
Camera Array Weight: 22.3 pounds 
Power Requirements:  110/120 VAC @ 60 Hz (220/240 VAC @ 50 Hz optional) 
 
Infrared Tag Dimensions 0.5 inches x 0.38 inches x 0.38 inches 
Tag Weight:   0.01 ounces (approximate) 
 
Tag Controller Dimensions: 5.5 inches x 5.5 inches x 1.5 inches 
Tag Controller Weight: 14.7 ounces (with batteries) 
Tag Controller Power:  2 AA alkaline batteries 
 
Maximum Sampling Rate: 900 tags per second (e.g. 30 Hz with 30 tags, 60 Hz with 15 
tags) 
Field of View:   40 degrees x 40 degrees 
System Range:  7 meters minimum 
Measurement Latency: 3 milliseconds 
 
RMS Acuracy:  

Distance from 
Sensor 

2 meters 4 meters 6 meters 

Field of View 0.90 m x 
1.44 m 

2.86 m x 
2.92 m 

4.08 m x 
4.37 

X and Y accuracy 0.7 mm 1.4 mm 2.1 mm 
Z accuracy 1.0 mm 2.0 mm 3.0 mm 

 
Measurement Limits:  Line of sight required 
 
Interface:   115.2Kbaud RS-232 Serial Port  
 
System Options:  Digitizing Probe for 3D digitizing applications 
    High-speed Ethernet interfaces 
 
Supplied Software:  Windows NT/95 capture, display, and data conversion 

application. 
Windows NT/95 & UNIX APIs for custom applications. 
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7. Appendix B - Text Commands 
‘s’  start capture session (data should start flowing) 
‘t’  stop capture session (data will stop flowing) 
‘z’  zero time parameters 
‘?’  Query device information 
‘#’  Query device serial number 
‘n<DDD>’ sets number of tags to be tracked 
‘X’  enable heartbeat clock 
‘Z’  disable heartbeat clock 
‘M’  enable clock period modification 
‘D’  toggle demo mode 
’f<DDD>’ set ID of first tag to be tracked 
‘l<DDD>’ set ID of last tag to be tracked 
‘i’  reset IrDA interface 
‘Q’  toggle to enable/disable the sending of quality information 
‘L’  toggle to enable/disable the transmission of raw CCD data 
‘S’  toggle to enable/disable the complete scan packet format 
 
‘.’  CAMERAS - Increment VGA gain by 1 
‘,’  CAMERAS - Decrement VGA gain by 1 
‘]’  CAMERAS - Increment PGA gain by 1 
‘[‘  CAMERAS - Decrement PGA gain by 1 
‘+’  CAMERAS - Increment PGA gain by 16 
‘-‘  CAMERAS - Decrement PGA gain by 16 
‘d’  CAMERAS - Set PGA/VGA gain to default - low (PGA=128, VGA=8) 
‘m’  CAMERAS - Set PGA/VGA gain to maximum (PGA=255, VGA=15) 
‘h’  CAMERAS - Set PGA/VGA gain to half (PGA=192, VGA=12) 
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